[Fixed] Warning: Information on some packages might not be actual: inconsistencies were detected in the system’s package manager database. Please resolve this issue manually.

In Uncategorized by UserHaven Admin

Fix inconsistencies in the Plesk Package manager

 

If you should ever run into an error like this, it’s very easy to fix.

IF You’re running Plesk 17 on a Fedora based distro (CentOS, CloudLinux, RedHat):

  1. Login via SSH
  2. Run the following
    # plesk sbin pum --check
  3. What you see here is the error that is causing the Warning message to appear. What you do next will depend on the type of error you are getting.
    1. In this case the error is the presence of duplicate packages.

Remove duplicate packages:

# yum install yum-utils -y

  • This time we will specifically check for duplicate packages.

# package-cleanup –dupes

      • The duplicate packages will be listed like this;
      • Be careful when doing this, that you can roll-back if something goes wrong.
      • Also ensure that no other package dependencies are being removed during the process either.
  • Now run the command to remove duplicate packages

# package-cleanup --cleandupes

  • When it’s done, check for inconsistencies again;

# plesk sbin pum --check

If your package manager is trying to remove other dependencies as well, and not just the duplicated package, then use the following;
# rpm -e --nodeps cloud-init.x86_64 0:0.7.9-9.el7.centos.2

RPM – for package manager
-e for erase
–nodeps for ‘no dependencies’
Followed by the package.

 

Hope that helps!

 

Sources;

Plesk update warning: Test Transaction Errors: package xxx (which is newer than xxx) is already installed

Information on some packages might not be actual: inconsistencies were detected in the system’s package manager database

System updates warning: Information on some packages might not be actual: inconsistencies were detected in the system’s package manager database. Please resolve this issue manually